Kunena 5.0.7

Home Forums Support Kunena 5.0.7


I initially installed Kunena 4.0.11 onto a clean install of joomla and then imported my tables. I then upgraded to 4.0.12. Yesterday I upgraded to 5.0.0 then to 5.0.4 and then to 5.0.7. I’m still reviewing the changelogs to see if I can upgrade to a newer version as I’m only running J!3.6.5 currently.

As I was checking out the forums to make sure all of the links & images worked I ran into a problem on the new topic page. All of the editor toolbar icons were gone. You could mouseover the “empty” space and the little label would appear telling you what it was that you were mousing over.
After over an hour of searching & reading it turns out that I have to turn off the css compression. Once I did that and refreshed the page the icons showed.

So now I have my css compression turned off because of Kunena & my javascript compression is turned off beccause of dpcalendar.

Do you know if there are fixes coming in the near future that will fix the compression settings allowing me to turn these options back on?


This reply has been marked as private, meaning that only the original poster and forum moderators can see the content of the reply.

Hi Danielle,

Did you try the “Exclude Javascript” feature when compressing js files ? Enter kunena js file(s) or dpcalendar js file(s) that caused the issue when compressing all js files then recheck.

Exclude Javascript

The current site is on production mode so you can take a backup then test the issue in local

No I haven’t tried excluding any javascript files, mostly because I don’t know how to work the feature. Do I use the exact js file name, or can I summarize? So I just felt I was better off safe than sorry, not using it.

I spent a little time researching the javascript exclusion feature to learn how to use it.

Putting dpcalendar.js in the box did not fix my problem. However, using advice for a completely unrelated extension did work. I added jquery.min.js to the exclude javascript box and it worked.

I’m still not sure about the Kunena problem though as I’ve read that it’s a css problem and not a javascript problem. So for now I’ll leave the css compression turned off. I’m just happy to be able to turn my javascript compression back on.

I will take a look the compress css feature with kunena and let you know if i found a solution for this case

Just a little update: I have since updated Kunena from 5.0.7 to 5.0.11 & J!3.6.5 to J!3.75. I’m also running the latest version of the helix platform as well and the problem still persists.

Just out of curiousity:
I have multiple copies of the Factory template as I’m getting ready to run a multilingual site. When I was running J!3.6.5 each template’s menu was in a nice little box with a scroll bar. Now when I go to the menu screen for each template the entire menu for each template is shown in it’s entirety. Was this done on purpose? An incompatibility between J!3.7.5 & Helix? It needs to back to way it was. It was way more pleasant on the eyes, plus easier to get to the menu that you wanted to assign that template too. (Just my two cents)


Hi Danielle,

I did a few tests with compress css/js feature, there’s a conflict issue with Kunena template when compress feature enabled. In this case, could you please use JCH Optimize for the site instead using core compress css/js helix3 feature?

With JCH Plugin you can control the files to compress (both css/js method) to avoid the issue kunena’s editor missing.

I will report this case for Helix3 dev team so they can fix it in next update.

You must be logged in to reply to this topic.